blob: 73c9cac866114acd349af3921d8c1eb79dfd1557 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="2"
DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications"
HOMEPAGE="http://www.celt-codec.org/"
SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0.5.1"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
IUSE="ogg static-libs"
DEPEND="ogg? ( media-libs/libogg )"
RDEPEND="${DEPEND}"
src_configure() {
econf \
$(use_enable static-libs static) \
$(use_with ogg ogg /usr)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc README TODO || die "dodoc failed."
use static-libs || find "${D}" -name '*.la' -delete
}