blob: 6fdab304211544c40cacab26d13dd5756619f6c1 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils games
DESCRIPTION="An Alien Invaders style game with 3d graphics"
HOMEPAGE="http://triplexinvaders.infogami.com"
SRC_URI="http://acm.jhu.edu/~arthur/invaders/${P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND="app-arch/unzip"
RDEPEND="dev-python/pygame
dev-python/pyopengl"
src_prepare() {
epatch "${FILESDIR}/${P}"-gentoo.patch
sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
sound.py \
util.py \
hiscore.py \
options.py || die "sed failed"
}
src_install() {
local libdir=$(games_get_libdir)
insinto "${libdir}/${PN}"
doins -r *.py
insinto "${GAMES_DATADIR}/${PN}"
doins -r models sound options.conf hiscores
games_make_wrapper ${PN} "python ./invaders.py" "${libdir}/${PN}"
dodoc README.txt TODO.txt
prepgamesdirs
}