blob: c886eb5768c649853ae936329295b9731bf3e3c7 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
#if LIVE
AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
inherit git-r3
#endif
inherit autotools-utils
DESCRIPTION="dev-util/squashdelta delta merge tool"
HOMEPAGE="https://bitbucket.org/mgorny/squashmerge/"
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="lz4 +lzo"
#if LIVE
KEYWORDS=
SRC_URI=
#endif
COMMON_DEPEND="
lz4? ( app-arch/lz4:0= )
lzo? ( dev-libs/lzo:2= )"
RDEPEND="${COMMON_DEPEND}
dev-util/xdelta:3"
DEPEND=${COMMON_DEPEND}
# SquashDelta does not make much sense without a compression algo.
REQUIRED_USE="|| ( lz4 lzo )"
DOCS=( FORMAT )
src_configure() {
local myeconfargs=(
$(use_enable lz4)
$(use_enable lzo)
)
autotools-utils_src_configure
}