blob: 7a2dac09e8cf383fa84339095926e1b78cd18bfb [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_RECIPE_DOC="yard"
RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
DESCRIPTION="The Hashery is a tight collection of Hash-like classes"
HOMEPAGE="https://rubyworks.github.com/hashery"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
ruby_add_bdepend "test? (
dev-ruby/lemon
dev-ruby/qed
dev-ruby/rubytest
dev-ruby/rubytest-cli )"
each_ruby_test() {
${RUBY} -S qed || die 'tests failed'
${RUBY} -S rubytest -Ilib -Itest test/ || die 'tests failed'
}