blob: 1d5fc6c017e253dd981a3e54c4d5ab39a931f51a [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README"
inherit multilib ruby-fakegem
DESCRIPTION="Simple wrapper around multithreaded Porter stemming algorithm"
HOMEPAGE="https://github.com/romanbsd/fast-stemmer"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
all_ruby_prepare() {
rm ext/Makefile || die
}
each_ruby_configure() {
${RUBY} -Cext extconf.rb || die
}
each_ruby_compile() {
emake V=1 -Cext
cp ext/stemmer$(get_modname) lib/ || die
}
each_ruby_test() {
${RUBY} -Ilib -S testrb test/fast_stemmer_test.rb || die
}