blob: c63efff47c614d1e1acb59f2e116562b5fbedbfb [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Tree widgets for urwid"
HOMEPAGE="https://github.com/pazz/urwidtrees"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]"
src_prepare() {
find "${S}" -name '*.py' -print0 | xargs -0 -- sed \
-e '1i# -*- coding: utf-8 -*-' -i || die
distutils-r1_src_prepare
local md
for md in *.md; do
mv "${md}" "${md%.md}"
done
}
src_compile() {
distutils-r1_src_compile
if use doc; then
pushd docs || die
emake html
popd || die
fi
}
src_install() {
distutils-r1_src_install
if use doc; then
dohtml -r docs/build/html/*
fi
}