blob: 5216c17f0b84af645936c80b3e0bd25d3979e7ac [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1 vcs-snapshot
DESCRIPTION="console colouring for python"
HOMEPAGE="http://gfxmonk.net/dist/0install/python-termstyle.xml"
SRC_URI="https://github.com/gfxmonk/${PN#*-}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
python_prepare_all() {
local PATCHES=(
"${FILESDIR}"/tests-unicode.patch
)
distutils-r1_python_prepare_all
}
python_test() {
if [[ "${EPYTHON}" = "python2.7" ]]; then
"${PYTHON}" test2.py || die "test2.py failed under ${EPYTHON}"
else
"${PYTHON}" test3.py || die "test3.py failed under ${EPYTHON}"
fi
}