blob: 9c21a59e32ec2efb72f445515e6472b52ba01522 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Python interface to libpcap"
HOMEPAGE="http://sourceforge.net/projects/pylibpcap/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~x86"
IUSE="examples"
RDEPEND="net-libs/libpcap"
DEPEND="${RDEPEND}"
python_install_all() {
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}