blob: 3d8f850d0ebc4a0bfe6d23a66338baa720ee758b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1 flag-o-matic
DESCRIPTION="Python bindings for ALSA library"
HOMEPAGE="http://alsa-project.org/"
SRC_URI="mirror://alsaproject/pyalsa/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE=""
RDEPEND="media-libs/alsa-lib"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
python_prepare_all() {
local PATCHES=(
"${FILESDIR}/${PN}-1.0.25-no-build-symlinks.patch"
)
distutils-r1_python_prepare_all
}
python_configure_all() {
# note: this needs changing when py3 becomes supported
append-flags -fno-strict-aliasing
}