blob: bbf3d67fecdef2ec72cced85522b7872741b0e35 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
DESCRIPTION="Pidfile featuring stale detection and file-locking"
HOMEPAGE="https://pypi.python.org/pypi/pid https://github.com/trbs/pid/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS="~amd64"
IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]"
python_test() {
nosetests || die
}