blob: 56090682916e7f8138046925d5e6b6ccaea0ee89 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
MY_PN="DecoratorTools"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Class, function, and metaclass decorators"
HOMEPAGE="https://pypi.python.org/pypi/DecoratorTools"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
LICENSE="|| ( PSF-2 ZPL )"
SLOT="0"
KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE=""
DEPEND="
app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
python_prepare_all() {
# Disable tests broken with named tuples.
sed -e "s/additional_tests/_&/" -i test_decorators.py || die "sed failed"
}
python_test() {
esetup.py test
}