blob: 13f125862b04fdd8e059aed9e77940b4ddfb3c49 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="3"
inherit common-lisp
DESCRIPTION="An ASDF-Extension to specify where your Common Lisp binaries (FASL files) should go"
HOMEPAGE="http://common-lisp.net/project/cl-containers/asdf-binary-locations/"
SRC_URI="http://common-lisp.net/project/portage-overlay/distfiles/${PN}_${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE=""
DEPEND="dev-lisp/asdf"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
CLPACKAGE=${PN}
src_install() {
insinto $CLSOURCEROOT/$CLPACKAGE/dev
doins dev/*.lisp
common-lisp-install *.asd
common-lisp-system-symlink
}