blob: 5f212d06cdb408dcea474955f772a12fa7b294d0 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit unpacker games
DESCRIPTION="Quake4 SDK"
HOMEPAGE="http://www.iddevnet.com/quake4/"
SRC_URI="mirror://idsoftware/quake4/source/linux/quake4-linux-${PV}-sdk.x86.run"
LICENSE="QUAKE4"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE=""
RESTRICT="strip"
S=${WORKDIR}
src_unpack() {
unpack_makeself
rm -rf setup.{sh,data} || die
}
src_install() {
insinto "${GAMES_PREFIX_OPT}/${PN}"
doins -r *
prepgamesdirs
}