blob: fd649987125c4ec568bdcca9fc3deeaa30289117 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
AUTOTOOLS_AUTO_DEPEND="yes"
inherit eutils autotools-multilib
DESCRIPTION="A high-speed compression/decompression library by Google"
HOMEPAGE="https://github.com/google/snappy"
# upstream uses google drive which has hash-based URLS
SRC_URI="https://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
src_prepare() {
# Avoid automagic lzo and gzip by not checking for it
sed -i '/^CHECK_EXT_COMPRESSION_LIB/d' configure.ac || die
# don't install unwanted files
sed -i 's/COPYING INSTALL//' Makefile.am || die
eautoreconf
}
multilib_src_configure() {
ECONF_SOURCE=${S} \
econf \
--docdir='$(datarootdir)'/doc/${PF} \
--without-gflags \
--disable-gtest \
$(use_enable static-libs static)
}
multilib_src_install_all() {
prune_libtool_files
}