Add min_sdk_version to ndk_libandroid_support

This CL adds the same min_sdk_version to ndk_libandroid_support as for
the other ndk_prebuilt_static_stl targets in this Android.bp, allowing
it to be depended on from AdServices.

Test: m
Bug: 228842813
Change-Id: I599b15ddaf43a933137ab09550eabeea25890a96
diff --git a/Android.bp b/Android.bp
index 75a461c..61ccdd4 100644
--- a/Android.bp
+++ b/Android.bp
@@ -38,6 +38,7 @@
 
 ndk_prebuilt_static_stl {
     name: "ndk_libandroid_support",
+    min_sdk_version: "33",
     export_include_dirs: [
         "current/sources/android/support/include",
     ],