CarLensPickerApp: Remove nonexistent required modules

TARGET module CarLensPickerApp requires non-existent: privapp_whitelist_com.android.car.lenspicker

Bug: 7456955
Test: No product is using CarLensPickerApp, so only test TH presubmit
Change-Id: I527110ce93b2bcbf2ef81ad6bbc9d10b1b8aa709
diff --git a/Android.bp b/Android.bp
index 4c0bf46..9dfa8ca 100644
--- a/Android.bp
+++ b/Android.bp
@@ -37,5 +37,4 @@
             enabled: false,
         },
     },
-    required: ["privapp_whitelist_com.android.car.lenspicker"]
 }