Move to Android Gradle Plugin 2.4.0 alpha 6.

Bug: 37321102
Test: ./gradlew assemble assembleAndroidTest createArchive generateDocs
Change-Id: If675ac8bff8e89ab1e6e3d4ee9507fdb3578ec48
(cherry picked from commit 04cccc992a4bf6f2ad3a28d68bd785ca38045b1c)
diff --git a/buildSrc/dependencies.gradle b/buildSrc/dependencies.gradle
index 0e5460f..6adb4de 100644
--- a/buildSrc/dependencies.gradle
+++ b/buildSrc/dependencies.gradle
@@ -26,7 +26,7 @@
 libs.espresso_contrib = 'com.android.support.test.espresso:espresso-contrib:2.3-alpha'
 
 // Keep gradle plugin version in sync with ub_supportlib-master manifest.
-libs.gradle = 'com.android.tools.build:gradle:2.4.0-alpha5'
+libs.gradle = 'com.android.tools.build:gradle:2.4.0-alpha6'
 
 // Other dependencies
 libs.xml_parser_apis = 'xerces:xmlParserAPIs:2.6.2'