Update support lib version to 23.1.0-dev

Change-Id: I76647e131872590d893014b7a733cb6393fe25db
diff --git a/build.gradle b/build.gradle
index a0ff782..30290fe 100644
--- a/build.gradle
+++ b/build.gradle
@@ -9,7 +9,7 @@
     }
 }
 
-ext.supportVersion = '23.0.1'
+ext.supportVersion = '23.1.0-dev'
 ext.extraVersion = 19
 ext.supportRepoOut = ''
 ext.buildToolsVersion = '22.1.0'