Used LOCAL_SHARED_LIBRARIES for proper dependencies

bug:15938254
Change-Id: I710f689e8bcad66988ef3aa0aa189b185c8ad662
diff --git a/packages/PrintSpooler/jni/Android.mk b/packages/PrintSpooler/jni/Android.mk
index fbf56be..fe7d06b 100644
--- a/packages/PrintSpooler/jni/Android.mk
+++ b/packages/PrintSpooler/jni/Android.mk
@@ -9,9 +9,9 @@
     $(JNI_H_INCLUDE)
 
 LOCAL_SHARED_LIBRARIES := \
-    libnativehelper
-
-LOCAL_LDLIBS := -lm -llog -ljnigraphics
+    libnativehelper \
+    libjnigraphics \
+    liblog
 
 LOCAL_MODULE := libprintspooler_jni
 LOCAL_MODULE_TAGS := optional