Revert "Set minimum SDK level to 10.7 for Mac and iOS" (r7175)

Reverting this since it didn't fix the build failures.
We ended up passing mac_sdk=10.9 in GYP_DEFINES on the bots
to to make the build pass again
(https://codereview.chromium.org/573673002).

BUG=3120
R=mcasas@webrtc.org, tommi@webrtc.org

Review URL: https://webrtc-codereview.appspot.com/24669004

git-svn-id: http://webrtc.googlecode.com/svn/trunk@7275 4adac7df-926f-26a2-2b94-8c16560cd09d
diff --git a/webrtc/build/common.gypi b/webrtc/build/common.gypi
index 92404fd..fdf1abe 100644
--- a/webrtc/build/common.gypi
+++ b/webrtc/build/common.gypi
@@ -148,11 +148,6 @@
         'include_tests%': 1,
         'restrict_webrtc_logging%': 0,
       }],
-      ['OS=="mac" or OS=="ios"', {
-        # Set the minimum SDK level to 10.7 since we need AVFoundation.
-        # See ../build/common.gypi for more info about this variable.
-        'mac_sdk_min%': '10.7',
-      }],
       ['OS=="ios"', {
         'build_libjpeg%': 0,
         'enable_protobuf%': 0,