Make libselinux symbols versioned

Since R, stub variants of libselinux are created. They are used when
libselinux is requested from APEXes. Depending on the min_sdk_version
requirement of the APEX, we need to use different versions of libselinux
stubs. For example, an APEX that started with Android R should be linked
with R stub of libselinux, even it's built in Android S source tree
which might have a few more APIs. Otherwise, the APEX built in S won't
be able to work on R devices.

The stub generator (build/soong/cc/gen_stub_libs.py) uses symbol version
for identifying which version of Android the symbol was first
introduced. So, in this change, the existing symbols are all assigned
with a symbol version LIBSELINUX_R. For the symbols that will be added
for S should be assigned with a different symbol version, e.g.

LIBSELINUX_S { # introduced=S
   new_symbol;
   new_symbol2;
};

Bug: 151053366
Bug: 150999716
Test: m
Change-Id: I2d5966fbc9d255cc6a12aede88ee5f89987b5089
diff --git a/libselinux/exported.map b/libselinux/exported.map
index fbc8acc..89a3117 100644
--- a/libselinux/exported.map
+++ b/libselinux/exported.map
@@ -1,4 +1,4 @@
-{
+LIBSELINUX_R {
   global:
     fgetfilecon;
     fgetfilecon_raw;