Upgrade rust/crates/syn-mid to 0.5.1

Test: make
Change-Id: Idd826c6a3281490df812082623c6c9ba0dc0cacb
24 files changed
tree: 5d9e8bb9f19ed4036217424d1acd7c65e4cc5eac
  1. .cargo_vcs_info.json
  2. .editorconfig
  3. .gitattributes
  4. .github/
  5. .gitignore
  6. Android.bp
  7. CHANGELOG.md
  8. CODE_OF_CONDUCT.md
  9. Cargo.toml
  10. Cargo.toml.orig
  11. LICENSE-APACHE
  12. LICENSE-MIT
  13. METADATA
  14. MODULE_LICENSE_APACHE2
  15. OWNERS
  16. README.md
  17. TEST_MAPPING
  18. ci/
  19. rustfmt.toml
  20. scripts/
  21. src/
README.md

syn-mid

crates-badge docs-badge license-badge rustc-badge

Providing the features between “full” and “derive” of syn.

This crate provides the following two unique data structures.

  • syn_mid::ItemFn -- A function whose body is not parsed.

    fn process(n: usize) -> Result<()> { ... }
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ ^     ^
    
  • syn_mid::Block -- A block whose body is not parsed.

    { ... }
    ^     ^
    

Other data structures are the same as data structures of syn. These are defined in this crate because they cannot be used in syn without “full” feature.

Usage

Add this to your Cargo.toml:

[dependencies]
syn-mid = "0.5"

The current syn-mid requires Rust 1.31 or later.

Examples

Optional features

  • clone-impls — Clone impls for all syntax tree types.

License

Licensed under either of

at your option.

Contribution

Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in the work by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any additional terms or conditions.