Merge "Make libfutures_executor available to DnsResolver" am: 2906200268

Original change: https://android-review.googlesource.com/c/platform/external/rust/crates/futures-executor/+/1742275

Change-Id: I6e13821f27f4ef71373e51364aaecb5151b4456e
diff --git a/Android.bp b/Android.bp
index 59ce04f..c6ba129 100644
--- a/Android.bp
+++ b/Android.bp
@@ -58,8 +58,10 @@
     ],
     apex_available: [
         "//apex_available:platform",
+        "com.android.resolv",
         "com.android.virt",
     ],
+    min_sdk_version: "29",
 }
 
 // dependent_library ["feature_list"]
diff --git a/cargo2android.json b/cargo2android.json
index e195a6a..05ca777 100644
--- a/cargo2android.json
+++ b/cargo2android.json
@@ -1,8 +1,10 @@
 {
   "apex-available": [
     "//apex_available:platform",
+    "com.android.resolv",
     "com.android.virt"
   ],
+  "min_sdk_version": "29",
   "dependencies": true,
   "device": true,
   "features": "thread-pool",