Bug: 179316330

Clone this repo:
  1. f7dcdf2 Upgrade crossbeam-utils to 0.8.19 am: 6e8d2d5a50 by Jeff Vander Stoep · 3 months ago emu-34-2-dev main master
  2. 6e8d2d5 Upgrade crossbeam-utils to 0.8.19 by Jeff Vander Stoep · 3 months ago emu-34-3-release
  3. 4ea1f2a Migrate to cargo_embargo. am: 2797491abe am: 52e56157eb am: 70ed4009e5 by Andrew Walbran · 5 months ago
  4. 3df28a2 Migrate to cargo_embargo. am: 2797491abe am: ad9b4ae9ce am: a5c58f765c by Andrew Walbran · 5 months ago
  5. 70ed400 Migrate to cargo_embargo. am: 2797491abe am: 52e56157eb by Andrew Walbran · 5 months ago

Crossbeam Utils

Build Status License Cargo Documentation Rust 1.60+ chat

This crate provides miscellaneous tools for concurrent programming:

Atomics

  • AtomicCell, a thread-safe mutable memory location.(no_std)
  • AtomicConsume, for reading from primitive atomic types with “consume” ordering.(no_std)

Thread synchronization

  • Parker, a thread parking primitive.
  • ShardedLock, a sharded reader-writer lock with fast concurrent reads.
  • WaitGroup, for synchronizing the beginning or end of some computation.

Utilities

  • Backoff, for exponential backoff in spin loops.(no_std)
  • CachePadded, for padding and aligning a value to the length of a cache line.(no_std)
  • scope, for spawning threads that borrow local variables from the stack.

Features marked with (no_std) can be used in no_std environments.

Usage

Add this to your Cargo.toml:

[dependencies]
crossbeam-utils = "0.8"

Compatibility

Crossbeam Utils supports stable Rust releases going back at least six months, and every time the minimum supported Rust version is increased, a new minor version is released. Currently, the minimum supported Rust version is 1.60.

License

Licensed under either of

at your option.

Contribution

Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in the work by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any additional terms or conditions.