Merge pull request #207 from niklasf/unsafe-from-bits-unchecked

Document from_bits_unchecked unsafety (#200)
tree: e7ab1cda787116be024bc6a87ca769069004ab2c
  1. .gitignore
  2. .travis.yml
  3. CHANGELOG.md
  4. CODE_OF_CONDUCT.md
  5. Cargo.toml
  6. LICENSE-APACHE
  7. LICENSE-MIT
  8. README.md
  9. bors.toml
  10. build.rs
  11. src/
  12. test_suite/
README.md

bitflags

Build Status Join the chat at https://gitter.im/bitflags/Lobby Latest version Documentation Minimum rustc version License

A Rust macro to generate structures which behave like a set of bitflags

Usage

Add this to your Cargo.toml:

[dependencies]
bitflags = "1.2"

and this to your crate root:

#[macro_use]
extern crate bitflags;

Rust Version Support

The minimum supported Rust version is 1.20 due to use of associated constants.