dumb_driver: should be rgb565

bgr565 is not required, but what's required from Android gralloc is
mapped to DRM_FORMAT_RGB565.

BUG=n/a
TEST=n/a

Disallow-Recycled-Builds: test-failures
Change-Id: Ic0ed0fb1accde364e3f676d9a02cf3a7d735e33a
Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/minigbm/+/3291888
Tested-by: Yiwei Zhang <zzyiwei@chromium.org>
Commit-Queue: Yiwei Zhang <zzyiwei@chromium.org>
Reviewed-by: Jason Macnak <natsu@google.com>
Reviewed-by: Chia-I Wu <olv@google.com>
diff --git a/dumb_driver.c b/dumb_driver.c
index 6dd83d8..ef7dd36 100644
--- a/dumb_driver.c
+++ b/dumb_driver.c
@@ -25,7 +25,7 @@
 
 static const uint32_t scanout_render_formats[] = { DRM_FORMAT_ARGB8888, DRM_FORMAT_XRGB8888,
 						   DRM_FORMAT_ABGR8888, DRM_FORMAT_XBGR8888,
-						   DRM_FORMAT_BGR888,	DRM_FORMAT_BGR565 };
+						   DRM_FORMAT_BGR888,	DRM_FORMAT_RGB565 };
 
 static const uint32_t texture_only_formats[] = { DRM_FORMAT_NV12, DRM_FORMAT_NV21,
 						 DRM_FORMAT_YVU420, DRM_FORMAT_YVU420_ANDROID };