Set min_sdk_version to be part of mainline modules

Modules contributing mainline modules (APK/APEX) should set
min_sdk_version as well as apex_available.

"apex_inherit" is a special alias to represent "the minimum of all
that the apexes require".

For now setting min_sdk_version doesn't change build outputs.
But build-time checks will be added soon.

Bug: 152655956
Test: m
Change-Id: I3415af31f0d67e2e4c1fc5b7fdd188d6686ad535
1 file changed