blob: 9b18c8506d4f22767d415a743a593a1dda8a8abc [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
inherit eutils gnome2 readme.gentoo
DESCRIPTION="The Gnome Terminal"
HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
LICENSE="GPL-3+"
SLOT="0"
IUSE="debug +gnome-shell +nautilus vanilla"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
# FIXME: automagic dependency on gtk+[X]
RDEPEND="
>=dev-libs/glib-2.40:2[dbus]
>=x11-libs/gtk+-3.10:3[X]
>=x11-libs/vte-0.40.2:2.91
>=gnome-base/dconf-0.14
>=gnome-base/gsettings-desktop-schemas-0.1.0
sys-apps/util-linux
x11-libs/libSM
x11-libs/libICE
gnome-shell? ( gnome-base/gnome-shell )
nautilus? ( >=gnome-base/nautilus-3 )
"
# itstool required for help/* with non-en LINGUAS, see bug #549358
# xmllint required for glib-compile-resources, see bug #549304
DEPEND="${RDEPEND}
app-text/yelp-tools
dev-libs/libxml2
dev-util/desktop-file-utils
dev-util/gdbus-codegen
dev-util/itstool
>=dev-util/intltool-0.50
sys-devel/gettext
virtual/pkgconfig
"
DOC_CONTENTS="To get previous working directory inherited in new opened
tab you will need to add the following line to your ~/.bashrc:\n
. /etc/profile.d/vte.sh"
src_prepare() {
gnome2_src_prepare
if ! use vanilla; then
# Fedora patch, https://bugzilla.gnome.org/show_bug.cgi?id=695371
epatch "${FILESDIR}"/${PN}-3.16.2-restore-transparency.patch
# Fedora patch, https://bugzilla.gnome.org/show_bug.cgi?id=721932
epatch "${FILESDIR}"/${PN}-3.16.2-restore-dark.patch
fi
}
src_configure() {
gnome2_src_configure \
--disable-static \
--disable-migration \
$(use_enable debug) \
$(use_enable gnome-shell search-provider) \
$(use_with nautilus nautilus-extension) \
VALAC=$(type -P true)
}
src_install() {
DOCS="AUTHORS ChangeLog HACKING NEWS"
gnome2_src_install
readme.gentoo_create_doc
}
pkg_postinst() {
gnome2_pkg_postinst
readme.gentoo_print_elog
}