blob: 145af654ed4c0b69dd5066e6d62b7c97c79cc8a1 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
inherit waf-utils multilib-minimal python-single-r1 eutils
DESCRIPTION="A simple database API"
HOMEPAGE="http://tdb.samba.org/"
SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
IUSE="python"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="
${RDEPEND}
${PYTHON_DEPS}
app-text/docbook-xml-dtd:4.2"
WAF_BINARY="${S}/buildtools/bin/waf"
src_prepare() {
python_fix_shebang .
multilib_copy_sources
}
multilib_src_configure() {
local extra_opts=()
if ! multilib_is_native_abi || ! use python; then
extra_opts+=( --disable-python )
fi
waf-utils_src_configure \
"${extra_opts[@]}"
}
multilib_src_compile() {
# need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
unset MAKEOPTS
waf-utils_src_compile
}
multilib_src_test() {
# the default src_test runs 'make test' and 'make check', letting
# the tests fail occasionally (reason: unknown)
emake check
}
multilib_src_install() {
waf-utils_src_install
}