blob: 7e7ad853c8ce789f1b81b673acb6301582f0c738 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Interact with the EFI Boot Manager"
HOMEPAGE="http://developer.intel.com/technology/efi"
SRC_URI="http://linux.dell.com/efibootmgr/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ia64 ~x86"
IUSE=""
RDEPEND="sys-apps/pciutils"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_unpack() {
unpack ${A}
cd "${S}"
sed -i \
-e "/^LIBS/s:=.*:=$($(tc-getPKG_CONFIG) libpci --libs):" \
src/efibootmgr/module.mk || die
}
src_compile() {
strip-flags
tc-export CC
emake EXTRA_CFLAGS="${CFLAGS}" || die
}
src_install() {
# build system uses perl, so just do it ourselves
dosbin src/efibootmgr/efibootmgr || die
doman src/man/man8/efibootmgr.8
dodoc AUTHORS README doc/ChangeLog doc/TODO
}