blob: b2a3fe31342acabc92ec0d013521e27ebd436812 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
PYTHON_DEPEND="2:2.5"
inherit python
DESCRIPTION="AnteChamber PYthon Parser interfacE"
HOMEPAGE="https://code.google.com/p/acpype/"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE=""
DEPEND="sci-chemistry/ambertools"
RDEPEND="${DEPEND}"
pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
src_prepare() {
python_convert_shebangs -r 2 .
}
src_install() {
newbin ${PN}.py ${PN}
newbin CcpnToAcpype.py CcpnToAcpype
dodoc NOTE.txt README.txt
insinto /usr/share/${PN}
doins -r ffamber_additions test
}