blob: 472f545e252c2abd77d6f7425c9e52edc20bfa0a [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
KDE_HANDBOOK="optional"
KMNAME="kde-workspace"
inherit kde4-meta
DESCRIPTION="KDE menu editor"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug"
RDEPEND="
$(add_kdebase_dep khotkeys)
"
DEPEND=${RDEPEND}
KMEXTRACTONLY="
libs/kworkspace/
"
src_configure() {
sed -i -e \
"s:\${CMAKE_CURRENT_BINARY_DIR}/../khotkeys/app/org.kde.khotkeys.xml:${EPREFIX}/usr/share/dbus-1/interfaces/org.kde.khotkeys.xml:g" \
kmenuedit/CMakeLists.txt \
|| die "sed failed"
kde4-meta_src_configure
}