blob: ea8d424927826ce25e1b0d2af4db1cc24a49e127 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit autotools eutils toolchain-funcs
DESCRIPTION="Computes changes between binary or text files and creates deltas"
HOMEPAGE="https://xdelta.googlecode.com/"
SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
IUSE=""
RDEPEND=">=dev-libs/glib-2
>=sys-libs/zlib-1.1.4"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-m4.patch
epatch "${FILESDIR}"/${P}-glib2.patch
epatch "${FILESDIR}"/${P}-pkgconfig.patch
eautoreconf
}
src_compile() {
tc-export CC
econf || die "econf failed"
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README
}