blob: afe7c165c9efd84407629645d60403a2cad1f450 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{3_3,3_4} )
inherit linux-info python-r1 toolchain-funcs
DESCRIPTION="report file access events from all running processes"
HOMEPAGE="https://launchpad.net/fatrace"
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="powertop"
RDEPEND="powertop? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
REQUIRED_USE="powertop? ( ${PYTHON_REQUIRED_USE} )"
CONFIG_CHECK="~FANOTIFY"
src_prepare() {
tc-export CC
}
src_install() {
dosbin fatrace
use powertop && dosbin power-usage-report
doman fatrace.1
dodoc NEWS
}