blob: 6cb31e69f387679fa189da45faa305553f5f8800 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.txt"
inherit ruby-fakegem
DESCRIPTION="Trollop is a commandline option parser for Ruby"
HOMEPAGE="http://trollop.rubyforge.org/"
LICENSE="Ruby"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
SLOT="0"
IUSE=""
each_ruby_test() {
${RUBY} -I lib test/test_trollop.rb || die "Tests failed."
}