blob: 999f561d3ccfbd73daf13cd0b5670c03929c37cf [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
inherit ruby-ng-gnome2
DESCRIPTION="Ruby poppler-glib bindings"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND+=" app-text/poppler[cairo]"
DEPEND+=" app-text/poppler[cairo]"
ruby_add_rdepend "dev-ruby/ruby-gdkpixbuf2
>=dev-ruby/ruby-glib2-${PV}
>=dev-ruby/ruby-gtk2-${PV}"
all_ruby_prepare() {
# Avoid compilation of dependencies during test.
sed -i -e '/if have_make/,/^ end/ s:^:#:' test/run-test.rb || die
}
each_ruby_test() {
${RUBY} test/run-test.rb || die
}