blob: b16ed87d1c405ad1f252aef2da865e60c8c3d501 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"
inherit virtualx ruby-ng-gnome2
DESCRIPTION="Ruby GStreamer bindings"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="${RDEPEND}
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0"
DEPEND="${DEPEND}
dev-libs/gobject-introspection
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0"
ruby_add_rdepend "
~dev-ruby/ruby-glib2-${PV}
~dev-ruby/ruby-gobject-introspection-${PV}
"
all_ruby_prepare() {
# Avoid compilation of dependencies during test.
sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
}
each_ruby_test() {
VIRTUALX_COMMAND="${RUBY} test/run-test.rb"
virtualmake || die
}