blob: 125fb0a1c79bdce2ca991b337c4392d347c66de6 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_EXTRADOC="README"
inherit ruby-fakegem
DESCRIPTION="Descriptive block syntax definition for Test::Unit"
HOMEPAGE="http://dust.rubyforge.org/"
LICENSE="MIT"
KEYWORDS="amd64 x86"
SLOT="0"
IUSE=""
# Remove a long-obsolete rubygems method.
all_ruby_prepare() {
sed -i '/manage_gems/d' rakefile.rb || die "Unable to update rakefile.rb"
}
each_ruby_test() {
${RUBY} -I. test/all_tests.rb || die
}