blob: 69d7fcb7808193992b79501823260674b8dffcc5 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.3.3.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit base haskell-cabal
MY_PN="MissingH"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Large utility library"
HOMEPAGE="http://software.complete.org/missingh"
SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS=" amd64 x86 ~amd64-linux"
IUSE=""
RDEPEND="dev-haskell/hslogger:=[profile?]
dev-haskell/hunit:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/network:=[profile?]
dev-haskell/parsec:=[profile?]
dev-haskell/random:=[profile?]
dev-haskell/regex-compat:=[profile?]
>=dev-lang/ghc-6.12.1:=
"
DEPEND="${RDEPEND}
virtual/libiconv
>=dev-haskell/cabal-1.8.0.2
test? ( dev-haskell/quickcheck
dev-haskell/testpack )
"
# libiconv is needed for the trick below to make it compile with ghc-6.12
S="${WORKDIR}/${MY_P}"
PATCHES=("${FILESDIR}/${PN}-1.2.0.2-ghc-7.7.patch")
src_prepare() {
base_src_prepare
# (non-ASCII non-UTF-8 source breaks hscolour)
cd src/System/Time
mv ParseDate.hs ParseDate.hs.ISO-8859-1
iconv -f ISO-8859-1 -t UTF-8 -c ParseDate.hs.ISO-8859-1 > ParseDate.hs || die "unable to recode ParseDate.hs to UTF-8"
}