blob: 84892e554c89d2a9d72f98379584bbf30d370f93 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.4.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal elisp-common
DESCRIPTION="Source code suggestions"
HOMEPAGE="http://community.haskell.org/~ndm/hlint/"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="emacs +gpl"
RDEPEND=">=dev-haskell/ansi-terminal-0.6.2:=[profile?]
>=dev-haskell/cmdargs-0.10:=[profile?]
>=dev-haskell/cpphs-1.18.1:=[profile?]
>=dev-haskell/extra-0.5:2=[profile?]
>=dev-haskell/haskell-src-exts-1.16:=[profile?] <dev-haskell/haskell-src-exts-1.17:=[profile?]
>=dev-haskell/transformers-0.0:=[profile?]
>=dev-haskell/uniplate-1.5:=[profile?]
>=dev-lang/ghc-7.4.1:=
gpl? ( >=dev-haskell/hscolour-1.21:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
SITEFILE="60${PN}-gentoo.el"
src_configure() {
local threaded_flag=""
if $(ghc-supports-threaded-runtime); then
threaded_flag="--flags=threaded"
else
threaded_flag="--flags=-threaded"
fi
haskell-cabal_src_configure \
$(cabal_flag gpl gpl) \
$threaded_flag
}
src_compile() {
cabal_src_compile
use emacs && elisp-compile data/hs-lint.el
}
src_install() {
cabal_src_install
if use emacs; then
elisp-install ${PN} data/*.el data/*.elc || die "elisp-install failed."
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
doman data/hlint.1
}
pkg_postinst() {
ghc-package_pkg_postinst
use emacs && elisp-site-regen
}
pkg_postrm() {
use emacs && elisp-site-regen
}