blob: 45949beb7efe994d1ab552c819ee2c2ecb52e181 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.4.9999
#hackport: flags: buildtests:test
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="HDBC"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Haskell Database Connectivity"
HOMEPAGE="https://github.com/hdbc/hdbc"
SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="test" # Tests do not compile with time 1.5
RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/text:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
test? ( dev-haskell/hunit:=[profile?]
>=dev-haskell/quickcheck-2.0:2=[profile?]
>=dev-haskell/testpack-2.0:=[profile?] )
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag test buildtests)
}
src_test() {
# default tests
haskell-cabal_src_test || die "cabal test failed"
# built custom tests
"${S}/dist/build/runtests/runtests" || die "unit tests failed"
}
src_install() {
cabal_src_install
# if tests were enabled, make sure the unit test driver is deleted
rm -f "${ED}/usr/bin/runtests"
}