blob: f7fa68f2637cf02afb8d829bd20985660f72d8bb [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.4.9999
GTK_MAJ_VER="2"
MY_PV="${PV%.0.*}"
MY_P="${PN}-${MY_PV}"
#nocabaldep is for the fancy cabal-detection feature at build-time
CABAL_FEATURES="lib profile haddock hoogle hscolour nocabaldep"
inherit haskell-cabal
DESCRIPTION="Binding to the Gtk+ graphical user interface library"
HOMEPAGE="http://projects.haskell.org/gtk2hs/"
SRC_URI="mirror://hackage/packages/archive/${PN}/${MY_PV}/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1"
SLOT="${GTK_MAJ_VER}/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples +fmode-binary +gio"
RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
>=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
dev-haskell/mtl:=[profile?]
>=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
>=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-lang/ghc-7.4.1:=
dev-libs/glib:2
x11-libs/gtk+:${GTK_MAJ_VER}
gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
virtual/pkgconfig
"
src_configure() {
# Upstream has this enabled, so we might as well force it enabled to be sure.
cabal_src_configure \
--flags=deprecated \
$(cabal_flag fmode-binary fmode-binary) \
$(cabal_flag gio have-gio) \
--flags=-have-quartz-gtk
}