blob: 5a08efda08d539c2d9f316bd1f8f8f79a4f18767 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.4.6.9999
#hackport: flags: -usenativewindowslibraries,buildexamples:examples
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="ALUT"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="A binding for the OpenAL Utility Toolkit"
HOMEPAGE="https://github.com/haskell-openal/ALUT"
SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
RDEPEND=">=dev-haskell/openal-1.7:=[profile?] <dev-haskell/openal-1.8:=[profile?]
>=dev-haskell/statevar-1.1:=[profile?] <dev-haskell/statevar-1.2:=[profile?]
>=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
>=dev-lang/ghc-7.4.1:=
media-libs/freealut
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag examples buildexamples) \
--flag=-usenativewindowslibraries
}