blob: 7e03200ed70c0b7156d6b6bbe3e4afd0b2efba21 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
#if LIVE
AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
inherit git-r3
#endif
inherit autotools-utils
DESCRIPTION="A system-wide notifications module for libtinynotify"
HOMEPAGE="https://bitbucket.org/mgorny/libtinynotify-systemwide/"
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs"
RDEPEND="sys-process/procps:0=
x11-libs/libtinynotify:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( dev-util/gtk-doc )"
#if LIVE
KEYWORDS=
SRC_URI=
DEPEND="${DEPEND}
>=dev-util/gtk-doc-1.18"
#endif
src_configure() {
myeconfargs=(
$(use_enable doc gtk-doc)
)
autotools-utils_src_configure
}