blob: 60adfa6a2832c18eec441c98dbe9639555f92fc8 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=(python2_7 python3_{3,4} )
inherit distutils-r1
DESCRIPTION="Python subprocess interface"
HOMEPAGE="https://github.com/amoffat/sh"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
${PYTHON} test.py || die
}