blob: 732a0a95f6e93852148d14f9bc8f9e2e19e44678 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
MY_PN=${PN//-/.}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Sphinx extension: auto-generates API docs from Zope interfaces"
HOMEPAGE="https://pypi.python.org/pypi/repoze.sphinx.autointerface/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="repoze"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
"
S=${WORKDIR}/${MY_P}