blob: 97e22a84784068a7914aa66c6f03b757e8d9c728 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
DESCRIPTION="Core of Hachoir framework: parse and edit binary files"
HOMEPAGE="https://bitbucket.org/haypo/hachoir/wiki/hachoir-core https://pypi.python.org/pypi/hachoir-core"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_configure_all() {
mydistutilsargs=( --setuptools )
}
python_test() {
"${PYTHON}" test_doc.py || die "Tests fail with ${EPYTHON}"
}