blob: f23a0bf1b74a78ff9d97e2a287d8f105db806d3c [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
MY_PN="CouchDB"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Python library for working with CouchDB"
HOMEPAGE="https://code.google.com/p/couchdb-python/ https://pypi.python.org/pypi/CouchDB"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
S=${WORKDIR}/${MY_P}
# Tests require connectivity to a couchdb server.
# Re-enable when the ebuild is capable of starting a local couchdb
# instance.
RESTRICT=test
python_test() {
esetup.py test
}