blob: 38b3973f79cadffad16123aed4a35ee5854d47a6 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="Fast, simple object-to-object and broadcast signaling"
HOMEPAGE="http://discorporate.us/projects/Blinker/ https://pypi.python.org/pypi/blinker"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
nosetests -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
use doc && HTML_DOCS=( docs/html/. )
distutils-r1_python_install_all
}