Remove support for mis-encoded PKCS#8 DSA keys.

Previously, OpenSSL supported many different DSA PKCS#8 encodings. Only
support the standard format. One of the workaround formats (SEQUENCE of
private key and public key) seems to be a workaround for an old Netscape
bug. From inspection, NSS seems to have fixed this from the first open
source commit.

(cherry-picked from 440f1037716eca16f203edb8f03d4a59c92ae0cc)

Bug: 27449871
Change-Id: I1e097b675145954b4d7a0bed8733e5a25c25fd8e
Reviewed-by: Adam Langley <>
1 file changed